
NewsWatcher help topics

I do the NewsWatcher help topics using MS Word, then take screen shots using Flash-It to make the
PICT resources.

Warning: To get the correct results, use the Chooser to set the “ImageWriter” printer driver. If you 
work on this document with the printer set to, for example, a LaserWriter, it will be all screwed up.

Warning: When you take screen shots, make certain your monitor is set to black and white. If you 
take color screen shots, the resulting PICT resources will be absolutely humongous. They’re way 
too big in B&W as it is.



NewsWatcher Help

When you need help, use the following sources of information about NewsWatcher:

• About box. For general information about NewsWatcher, see the about box. Use the About 
NewsWatcher command in the menu.

• Balloon help. NewsWatcher has complete balloon help for all of its menus, commands, 
dialogs, and windows. Use the Show Balloons command in the  menu to turn on balloon 
help. Then point to items on the screen to see help balloons about them.

• Help topics. For summaries of how to perform common tasks in NewsWatcher, and for 
summaries of NewsWatcher’s keyboard shortcuts, use the help topics in the  menu. You are 
reading one of these help topics now. For a quick overview of NewsWatcher, read all the help 
topics in order. To go backward and forward one help topic at a time, click the arrows at the top
of the help topic window, or use the left and right arrow keys.

• User document. NewsWatcher has a comprehensive user document which contains both 
tutorial and reference information. You should read at least the tutorial parts of the user 
document. See the about box for instructions on how to get a copy of the user document. 
Although useful, NewsWatcher’s online help features are not a substitute for the user 
document. Please read the user document!



Getting Started

If you are new to Usenet, we recommend that you start by using the full group list window to 
browse in any of the groups which look interesting. To open a group, double-click its name, or 
select it and press the Return key. This opens a window listing the subjects and authors of all the 
current articles in the group. To open an article, double-click its line in the subject window, or select
it and press the Return key.

You might like to begin by exploring some of the “comp.sys.mac” groups. Another group you 
should explore is “news.announce.newusers”. Your organization may have set up local groups 
which you also might like to explore.

Tip: The full group list is very large. To quickly find a group, use the Find command in the Edit 
menu.

When you read the news using the full group list, NewsWatcher always shows you all of the 
available articles on your news server, whether you have already read them or not. To have 
NewsWatcher keep track of which articles you have read, and only show you the new ones, you 
need to create a “user group list”. See the next topic Subscribing and Unsubscribing for details
on how to do this.



Subscribing and Unsubscribing

Most people like to build a small list of groups which they are most interested in reading most of 
the time. This list is called your “user group list”. Adding a group to this list is called “subscribing”. 
Removing a group from this list is called “unsubscribing”.

To build your user group list, first make certain you have an “untitled” user group list window open 
on your screen. If you don’t have one, use the New Group Window command in the File menu to
create one. Also make certain the full group list window is visible. If it isn’t, use the Show Full 
Group List command in the Windows menu to make it visible.

To subscribe to a group, select it in the full group list, then drag it into your user group list window. 
To unsubscribe to a group, select it in your user group list window and press the Delete key. To 
rearrange the order of the groups in your user group list window, drag the groups.

Use the Save command in the File menu to save your user group list on your hard drive or floppy 
disk. Give the file whatever name you wish, for example “My News”. The picture below shows what
this file looks like on your hard drive or floppy disk:

In the future, when you want to read the news, double-click this file to run NewsWatcher instead of 
double-clicking the NewsWatcher program file. This runs NewsWatcher, opens your saved user 
group list, and checks to see if any new articles have appeared in your subscribed groups.



Reading the News

Here’s one efficient way to read the news:

1. Double-click your saved user group list file to run NewsWatcher.
2. Press the Return key to open the first group with new articles.
3. Use the down arrow key to advance down the list of articles until you get to one which looks 

interesting.
4. Press the Return key to open the interesting article.
5. When you finish reading the article, use the Next Article command in the News menu to 

advance to the next article in the thread.
6. When you get to the end of the thread, the Next Article command automatically returns to 

the subject window.
7 Repeat steps 3-6 until you have read all the interesting articles in the group.
8. When you finish reading all the interesting articles in a group, use the Next Group command 

in the News menu. NewsWatcher marks all the articles in the current group read, closes the 
current subject window, and then opens the subject window for the next group in your list 
which has unread messages. This is a very convenient shortcut for rapidly going through the 
news. Marking all the articles in a group read instead of reading all of them is called “catching 
up”.

9. Repeat steps 3-8 until you have read and caught up with all of your subscribed groups.
10. Use the Quit command in the File menu to quit. NewsWatcher asks if you want to save 

changes to your user group list. Click the Save button.



Reading Old Articles

Sometimes you may want to go back and reread an article which you have already read in an 
earlier newsreading session. There are several ways to do this:

• Open the group from the full group list instead of from your user group list. The full group list 
always shows all of the available articles on your server, whether you have read them or not.

• Use the Search command in the Special menu to search for the article. This is particularly 
useful if you remember all or part of the author’s name or the article’s subject.

• Select the group in your user group list window. Use the Mark Unread command in the 
News menu to mark the entire group unread. Open the group.

• Hold down the Option key while opening a group. NewsWatcher asks you to enter the most 
recent number of articles to fetch. Type a number which you think is big enough. We’ll use 50 
as an example (assuming the article you want is among the most recent 50 articles posted to 
this group). NewsWatcher resets the list of unread articles in your group to be the most recent 
50 articles, then opens the group to show you just those 50 articles.

• If the old article is the article to which the current article is a followup, look at the beginning of 
the article for an attribution line which contains a “message id” in angle brackets (<...>). Hold 
down the ⌘ key while clicking the message id. NewsWatcher opens the referenced article.

• If the old article is an earlier article in the thread you are currently reading, try using the Open 
All References command in the Special menu. This command opens the article to which the 
current article is a followup, then the article to which that article was a followup, and so on 
back to the beginning of the thread. 



Setting Your Sig and Other Prefs

You will probably want to create a “signature” which is automatically appended to the end all the 
news articles you post and mail messages you send. Your signature typically gives your name, 
organization, and email address. Many people like to include the URL for their web page, 
aphorisms, quotations, jokes, song lyrics, or other personal information. Here’s an example of a 
signature:

John Doe
Flunk University
j-doe@flunku.edu
<http://www.flunku.edu/people/jdoe/>

To create a signature, use the Preferences command in the File menu to open NewsWatcher’s 
preferences dialog. Then press the Topic popup menu at the top of the dialog and select the 
Signature topic. Type your signature in the field provided. Then click OK.

NewsWatcher has a large number of preferences which let you tailor the program to fit your 
particular tastes and needs. Use balloon help to get more information about each of the options.



Replying to Articles

To reply to an article, use the Reply command in the News menu. NewsWatcher opens a message 
window which you use to compose your reply.

There are three icons at the top of the message window. To check or uncheck an icon, click it.

News icon. If this icon is checked, the message is posted as a news article. 
Mail icon. If this icon is checked, the message is sent via email.
Self icon. If this icon is checked, a copy of the message is sent to yourself via email.

By default, NewsWatcher opens reply windows with just the news icon checked, so your reply is 
posted only as a followup article.  To send your reply via email instead of as a followup posting, 
uncheck the news icon and check the mail icon. To send your reply as both an email message and 
as a followup posting, check the mail icon. Leave the news icon checked, so both icons are 
checked.

NewsWatcher includes the text of the article to which you are replying, with “>” characters in front
of each line. This is called “quoting”. It is a standard on the Internet for both news and mail. Add 
your comments to the message. You should delete any parts of the quoted text to which you are 
not directly replying. Your comments should immediately follow the relevant sections of quoted 
text.

When you are ready to send the message, click the Send button.



Posting New Articles

To post a new article starting a new thread, first select the group to which you want to post the 
article in any group list window. Then use the New Message command in the News menu.

Type the subject of your article in the Subject field in the message window. Then press the Tab key 
to advance to the body field in the message window. Type the body of your article, then click the 
Send button.

You can post an article to more than one group if you wish. This is called “cross-posting”. To cross-
post, ⌘-click to select the groups to which you want to post the article, then use the New 
Message command. You can also add groups later if you wish by typing them in the message 
window’s Newsgroups field separated by commas.

Use cross-posting sparingly. Cross-posting to a large number of groups is considered very rude. 
NewsWatcher warns you if you try to cross-post to more than five groups, and it imposes an 
absolute limit of 50 groups for any single posting.



Saving and Printing Articles

To save an open article, use the Save command in the File menu.

You can also save articles from subject windows. You don’t have to open the articles to save them. 
Select one or more articles in a subject window, then use the Save command. NewsWatcher saves 
all of the articles you selected in order on a single file.

To append an article or articles to the end of an existing file, use the Append command in the File
menu.

To print an open article, use the Print command in the File menu. 

You can also print articles from subject windows. You don’t have to open the articles to print them. 
Select one or more articles in a subject window, then use the Print command.



Forwarding Articles

To forward a copy of an article via email, use the Forward or Redirect command in the News 
menu. NewsWatcher opens a message window containing a copy of the article. Type the address of
the person to whom you wish to forward the article, add any comments to the message, then click 
the Send button to send it.

The Forward command is appropriate for sending someone a copy of an article which you think 
they might find interesting, especially if you want to annotate the article with your own comments.
The header and body of the article are copied to the new message body, with quoting. When you 
mail the message, it is marked as from you. If the recipient replies to the message, the reply is 
sent to you.

The Redirect command is appropriate for sending yourself a copy of an interesting article, or for 
sending someone else a copy when you want replies to go to the poster rather than to you. The 
subject and other header lines are copied from the article. The body of the article is copied to the 
new message body, without quoting. When you mail the message, it is marked as from the original
poster of the article, “by way of” you. If the recipient replies to the message, the reply is sent to 
the poster of the article. Unlike all other messages, your signature is not appended to redirected 
messages.

To send yourself a copy of an article (e.g., to file it using your mail program’s filing system, or to 
save it to reply via email later), use the Redirect command. Uncheck the mail icon, check the self 
icon, then click the Send button.



Finding and Searching

Usenet is huge, and it can often be a problem finding things. NewsWatcher has two different 
features for finding information.

The first feature is the Find, Find Again, and Enter Selection commands in the Edit menu. Use 
these commands to locate information in NewsWatcher windows. These commands are quite fast, 
since they do not involve any kind of network operation. You can use these commands to find 
information in group and subject list windows as well as in article and text windows. The Find 
command asks you to enter the string for which you wish to search. The Find Again command 
uses the previous search string. The Enter Selection command makes the currently selected text 
the search string.

Tip: To quickly find a group in a group list window, use the Find command and type just the first 
few characters of each part of the group name separated by periods. For example, finding 
“co.sy.ma.co” in the full group list quickly jumps to the group comp.sys.mac.comm.

The second feature is the Search command in the Special menu. Use this command to search 
one or more groups on your news server to find articles matching search criteria. This command 
always involves a network operation. For example, you could use this command to quickly find all 
the articles in comp.sys.mac.system which were posted by anyone from Apple Computer.



Opening URLs

“Uniform Resource Locators” (URLs) are a standard notation on the Internet for identifying the 
locations of files and other kinds of information. People often use this notation in postings to refer 
to a resource which is available elsewhere on the net. For example,

<ftp://ftp.flunku.edu/pub/games/wild-tetris.sit.hqx>
(A file available via anonymous FTP)

<http://www.flunku.edu/pub/people/jdoe/>
(John Doe’s web page)

To access the resource referenced by a URL, hold down the  ⌘ key while clicking anywhere in the 
URL, or click anywhere in the URL and use the Open URL command in the Special menu.

In the first example above, NewsWatcher runs your FTP program (e.g., Fetch or Anarchie) to get a 
copy of the file. In the second example above, NewsWatcher runs your web program (e.g., 
Netscape, MacWeb, or Mosaic) to connect to the site and display the web page.

You can also ⌘-click message id references in angle brackets (<...>) to open referenced articles, 
and you can ⌘-click email addresses to send mail to people.



Extracting Binaries

Sometimes people attach files directly to their postings instead of referring to an FTP site. These 
files are commonly called “binaries”.  When an article contains an attached binary, NewsWatcher 
displays a small file icon in the top right corner of the article window:

To extract the binary and make a copy of the file on your hard drive, click the small file icon, or use
the Extract Binaries command in the Special menu.

You can also extract binaries from subject windows. You don’t have to open the articles to extract 
their binaries. Select one or more articles in a subject window, then use the Extract Binaries 
command.

Most attached files are encoded in “BinHex” or “uuencode” format. NewsWatcher uses helper 
programs to decode the files. Our recommended helper programs are StuffIt Expander™ and 
uuUndo. See NewsWatcher’s about box for instructions on how to get copies of these programs.



---------------------------



Working with Text

NewsWatcher uses the standard Mac conventions for working with text.

To insert text, click at the location where you want the new text to appear, then type the new text.

To select text, click at one end of the text and keep the mouse button held down while moving to 
the other end of the text. Or click at one end of the text, then hold down the Shift key while 
clicking at the other end of the text.

To select a word, double-click it.

To select all the text in a window or field, use the Select All command in the Edit menu.

To delete text, use the Delete key or the Clear command in the Edit menu.

To copy and move text, use the Cut, Copy, and Paste commands in the Edit menu.

The Forward delete key on the extended keyboard deletes the next character of text—the 
character following the insertion point.



Text Arrow Key Shortcuts

In text, the arrow keys work as follows:

Arrow With With With
key Option ⌘  ⌘ and
alone key key Option keys

Left arrow Left one Left one To beginning
character word of line

Right arrow Right one Right one To end
character word of line

Up arrow Up one To start of To top To beginning
line paragraph of window of text

Down arrow Down one To end of To bottom To end
line paragraph of window of text

You can repeat these keys to advance one more unit in the same direction. You can also use the 
Shift key together with any of the combinations shown in the table to extend a selection. 



Working with Lists

NewsWatcher uses the standard Mac conventions for working with lists.

To select a list item, click it.

To select more than one list item, hold down the ⌘ key while clicking the additional items.

To select a range of list items, click the item at one end of the range, then hold down the Shift key 
while clicking the item at the other end of the range.

To select all the items in a list, use the Select All command in the Edit menu.

To deselect all the items in a list, use the Deselect All command in the Edit menu, or click 
anywhere in the panel area at the top of the list window.



List Arrow Key Shortcuts

In lists, the up and down arrow keys work as follows:

Arrow With With
key ⌘ ⌘and
alone key Option keys

Up arrow Up one To top To beginning
item of window of list

Down arrow Down one To bottom To end
item of window of list

You can repeat these keys to advance one more unit in the same direction. You can also use the 
Shift key together with any of the combinations shown in the table to extend a selection.



Keypad Shortcuts



Main Keyboard Shortcuts

When you turn on the Main keyboard shortcuts option in the Newsreading Options 
preferences topic, the following keys on the main keyboard are shortcuts:

I or N Next article.
T Next thread.

J or G Next group.
M Mark read.
U Mark unread.
; Mark others read.

W Close window.
A Select all.

Space bar Next chunk.

The space bar is very useful. It scrolls down one page at a time until you get to the end of an 
article, then it does a next article operation.



Drag and Drop Shortcuts

The following shortcuts work with System 7.0 or later:

• To subscribe to groups, drag them to your user group list window.
• To rearrange groups in your user group list window, drag them.

The following shortcuts require System 7.5 or an earlier system which has Drag Manager 1.1 or 
later installed:

• To move groups between user group list windows, drag them.
• To move text, select the text, then drag it to its new location.
• To add more groups to a message window, drag them to the Newsgroups field.

The following shortcuts require System 7.5 or an earlier system which has both Drag Manager 1.1 
or later and the drag-aware Finder installed:

• To unsubscribe to groups, drag them to the Finder’s trashcan icon.
• To delete text, drag it to the Finder’s trashcan icon.
• To extract binaries, drag the small file icon from an article window to the Finder.
• To save articles from a subject window, drag them to the Finder.
• To save text, drag it to the Finder to create a text clipping file.
• To insert a clipping in a message window, drag the clipping file into the window.



More Shortcuts

Shift + Save, Save As, Append: Save only the selected text.
Shift + Print: Print only the selected text.
Shift + Paste: Paste as quotation.
Shift + Reply, Forward: Quote only the selected text in the reply or forwarded message.
Shift + Redirect: Copy only the selected text to the redirected message.
Shift + drag text: Insert dragged text with quoting.
Option + Save: Save As.
Option + Reply: Reverse normal settings of news and mail icons.
Option + Forward, Redirect: Forward or redirect article to yourself.
Option + Extract Binaries: Present standard file dialog even if default folder set.
Option + open group: Prompts for most recent number of articles to fetch.
Option + drag text: Copy instead of move.
Option + drag groups between two user group list windows: Copy instead of move.
Option + click attached file icon: Present standard file dialog even if default folder set.
⌘ + right arrow: Expand selected threads.

 ⌘ + left arrow: Collapse selected threads.
 ⌘ + click: Open URL or message id or email address.
 ⌘ + 1,2,3 (message windows): Toggle (check/uncheck) news, mail, and self icons.
 ⌘ + 1,2 (article windows): Go backward/forward one article.
 ⌘ + Period, or Escape: Cancel a long operation.

Tab: Advance to next field in dialog window.
Tab: Advance to next field or tab stop in message window.
Option + Tab: Advance to next field in message window.
Shift + Tab: Back up to previous field in dialog or message window.
Control + L: Insert spoiler character.


